Back
Degraded

difficulty in joining games

Started 16 Apr at 10:51am BST, resolved 16 Apr at 10:53am BST.

www.roblox.com
Resolved

we identified the root cause, reverted the change

Posted 16 Apr at 10:53am BST.
Created

We are aware of the issue. Our team is actively working on it.

Posted 16 Apr at 10:51am BST.