Back
Degraded

Degraded Performance Site-Wide
Started 23 Jan at 01:57pm GMT, resolved 23 Jan at 01:59pm GMT.
www.roblox.com
www.roblox.com
www.roblox.com
www.roblox.com
www.roblox.com
www.roblox.com
www.roblox.com
www.roblox.com
www.roblox.com
Resolved
Issue has been resolved.
Posted 23 Jan at 01:59pm GMT.
Updated
We identified the issue and apply a fix.
Posted 23 Jan at 01:58pm GMT.

Created
We're investigating the issue.
Posted 23 Jan at 01:57pm GMT.