Back
Degraded

Degraded Performance

Started 25 Dec at 07:42pm GMT, resolved 26 Dec at 05:43pm GMT.

www.roblox.com www.roblox.com
Resolved

Data store issue now recovered.

Posted 26 Dec at 05:43pm GMT.
Updated

We believe we have fixed the issue and are now monitoring recovery. Site should be fully functional in less than 10 minutes.

Posted 26 Dec at 05:39pm GMT.
Updated

We have identified the root cause of the issue. And the website should be fully functional in the next 30-40 minutes

Posted 26 Dec at 05:18pm GMT.
Created

Creators experience data store issues

Posted 25 Dec at 07:42pm GMT.